Status

Cloudflare-related issues

Resolved
Main Website Account Portal
Partial Outage

We are aware that a routing link from a major provider is currently affecting Cloudflare, resulting in intermittent outages to our public services. During this time, you may experience issues using our main website and account portal. However, our hosting platform continues to operate as normal. Customers using Cloudflare might be affected as well. We apologize for the inconvenience and will share an update once we have more information.

2019-06-24T12:10:47.000Z
Monitoring

All services are now operational. We are continuing to monitor the situation and will let you know of any changes.

2019-06-24T12:51:15.000Z
Resolved

The routing leak has been resolved and connectivity across the Internet should be returning to normal. We will be continuing to monitor the situation, but we consider the incident closed.